This change is all about wording, so that it is better aligned with what the code actually does and what is in the 1.4 branch
while we're editing this line, would be nice to extract this constant and give it a meaningful name. perhaps something like overdueDelayCleanupInterval?
and maybe this constant could be referenced in test cases to give some shape to the magic numbers that appear in such places?
Somehow I skipped your comment. I will address it in another diff. Although the constant doesn't have anything to do with the durations in the tests below.